+1

Anyone experiencing issues with the XTRF/Phrase connector today?

Kenneth Larmer 9 months ago in Home Portal / Classic Projects with CAT integration updated by Bartosz Budzyński 9 months ago 9

Hi Everyone, 

Is anyone experiencing issues with the XTRF/Phrase connector today?

We are SaaS and I noticed that an update was applied to our instance early this morning (9.7.16)

We have been experiencing errors since this morning between XTRF and Phrase TMS. The same error is showing in the logs for all affected projects:

Integration error: eu.xtrf.integration.cat.exceptions.GeneralIntegrationException: Integration error: { }


Thanks, 

Kenneth

Hi Kenneth,

Same here same error.

Quick fix, try creating projects without any Phrase templates in the Cat tool option ( but you have to do some manual work).

We are experiencing the same issue, but I don't think it is the update. We were on an earlier version and started experiencing the issue (maybe an update on the Phrase integration?) and updated to the latest version to see if it would be solved. We have also reported it as a bug, but it seems they are away today and are not even covering these critical issues...

+1

Thanks, Mihai and Alexandros.

We contacted the Phrase Help Desk, but they said it was an XTRF issue (naturally!).

I guess we must wait until tomorrow! :-(

+2

Hi,

This issue is related to the unannounced breaking changes in the latest release of Phrase, which was released on October 31st. It's important to stress that this problem is not XTRF-related. It appeared before the release of 9.7.16 and after the Phrase update and affects older versions of XTRF as well (for example, 9.6). The changes in the latest XTRF release are not related to integrations at all. Regression testing confirmed that the integration was working well.

As the issue is caused by changes in how termbases are handled, as a temporary workaround, we suggest extracting the TBs into a separate bundle or removing them from bundles altogether.

We will report this issue to Phrase as a blocker, and we encourage you to do the same. In the meantime, we have engaged our developers to adjust the integration to the introduced changes.

Best regards,

Bartosz Budzyński
Director of Technical Services
XTRF

Hi Bartosz,

 

Thank you for the update. I appreciate your taking the time to respond. 

I presumed the issue might be related to the recent Phrase update on October 31, despite Phrase Support indicating otherwise.

Could you please confirm if only the termbases (TBs) are affected by this issue? Consequently, as long as the bundles do not include TBs, the workflow should function properly, correct? Are the translation memories (TMs) unaffected by this issue?

Additionally, could you provide an estimated time for the adjustment in the integration process?

I appreciate your assistance and understanding.

Kind regards, 

Kenneth

Hi Kenneth,

Thank you for your message and your patience. Yes, it seems that only the termbases are affected. Translation memories should be working as expected and should not cause any issues.

So far, we have a confirmation from Phrase that the Oct 31st release caused the issue, and we know where the problem is. Phrase routed that to their engineering team, and we are waiting for the patch.

I truly appreciate your understanding.

Kind regards,

Bartosz

Hi Bartosz,

With this workaround we can still use our Phrase templates?

Kind regards,

Mihai

Hi Mihai, 

Yes, your templates should work if no terminology is passed through XTRF to Phrase.

Best,

Bartosz

+1

Hello everyone, 

We got a confirmation from Phrase that the issue was fixed, and our QA team has confirmed that your workflows should be back to normal now. :) 

Best regards,

Bartosz