0

How can I make vendor invoice numbering *not* start again at 1 next year?

Ted 5 months ago in Home Portal / Smart Projects updated by Reinis Straume (LMI:T) 4 months ago 5

I've managed to remove the year from invoice numbers, but I'd really like to keep numbering continuous once 2021 starts. I can't find where the setting is in the documentation provided. 

+1

Hi Ted,

The trigger for resetting numbering scheme is stored in "Counter evaluation rule" - whenever that value changes, counter goes back to the original setting. By default it is set to ${currentDate.year} which means that whenever the year changes counter is set back to initial value. 

If you'll put some constant like number 1 it will never reset. 


Hope that helps!

Best,

Bartosz

Fantastic, thank you so much, Bartosz!

Bartosz,


I tried your suggestion, but it's created a new problem.  Vendors are unable to invoice us and get this error.  I guess the process doesn't check to see if a number has been used already. :-(

I changed the counter evaluation rule back to the way it was before your suggestion.

Have you tried checking what's the largest used number and setting the next one as the starting point instead of 1?