0
Answered

Why doesn't XTRF automatically "Start Job" when the vendor accepts an offer?

translations 3 years ago updated by Sancho Leath 3 years ago 3

Why doesn't XTRF automatically start a job when the vendor accepts an offer?

Answer

Answer
Answered

It happens because not all previous jobs may be finished at the point. 


Let me come upo with an example. Imagine a simple TEP workflow. Translation is already in progress, so the jobs offers to the editors are sent. Translator does not use Partially Finish Job option so the next vendor would have nothing to work on. If the status had changed to Started, such Vendor will never get the files.

Answer
Answered

It happens because not all previous jobs may be finished at the point. 


Let me come upo with an example. Imagine a simple TEP workflow. Translation is already in progress, so the jobs offers to the editors are sent. Translator does not use Partially Finish Job option so the next vendor would have nothing to work on. If the status had changed to Started, such Vendor will never get the files.

I actually don't send out offers to the next Step vendors (Step 2) until the previous Step (Step 1) is done, so the next Step vendors will only have access to the files submitted by the current Step (Step 1) vendor.

Not sure whether this will provide more light, but we had a very similar question for which I received information that was new to me. The question was how to start the job automatically once the job offer is accepted, even if the preceding job is not yet finished (e.g. because PM is still collecting customer information in the initial Project Preparation step). Here is a hidden way to configure this in the Process Designer:


"For now it is possible to edit (in process designer) workflow to allow job to automatically "switch" it status to "started" once the job offer is accepted (regardless of job status). To do that, please follow below instruction: 

1) Please enter process designer and in section "automatically start job when" select option "any preceding job is ready" (it will work also if "none" of proceeding job is ready) 

2) In section "default vendor" set "none" 

3) From drop-down list select any rule (it is only necessary if the checkbox "start job when Vendor is selected is unticked - selecting rule will allow you to edit this field) 

4) Click on "Apply Changes" 

5) When you will send job offer select option "select Vendors Manually"

Once the job will be accepted by Vendor job status will automatically change to "started"